taultunleashed logoEQ2 Macros: MegaBot v2.8 - Buff Bot AND HUNTER BOT! Discussi : EverQuest 2 Premium Discussions - Page 2
newtopic  postreply
 [ 233 posts ]  Previous  1, 2, 3, 4, 5 ... 16  Next
blue large dot

EQ2 Macros: MegaBot v2.8 - Buff Bot AND HUNTER BOT! Discussi : EverQuest 2 Premium Discussions - Page 2

Posted: October 31st, 2005, 8:53 pm
 
djvj

Total Posts: 272
Joined: May 1st, 2004, 4:00 am
djvj's Reps: 0
User avatar
Active User > 50 Posts
Some more new things I have noticed. For some reason my buffbot will try to autoattack mobs that he see's while my offensive bot is searching for the closestcon. He will take out his weapon for no reason.

One more, I know you're loving me. A couple times, out of 10 or so pulls, my offensive stopped close to where the mobs were that he pulled (not even close to the safespot and yes its set to safespot) and started fighting them there. Not to mention my buffbot typed /stopfollow a loooong ways back and isn't even close.


Reply with quote
Posted: November 1st, 2005, 5:18 am
 
boxy21
boxy21's Reps:
User avatar
I noticed my buffbot attacking random mobs between pulls as well. She will also toggle in and out of combat about 5 times after a fight and does seem to forget to autofollow sometimes. I fixed the attacking on her own by changing all the con attack types to false. I don't know if this had anything to do with me setting up the /assist key as the default '.' or not.
Attacking breakable walls and vases does seem to cause the bots to still freak out though and they have to be told to stand down.


Reply with quote
Posted: November 1st, 2005, 5:20 am
 
richyrich
richyrich's Reps:
User avatar
djvj wrote:
Noticed a new prob, and it happens every fight. My buffbot is always on follow on my offensive (so he is never too far to heal). Well with 2.7 this never happened. Offensive pulls a mob, starts running back to safespot. Offensive will stop and turn around and start to attack at safespot, but buffbot will of stopped sooner (either pressed back or foward and lost autofollow) to start his initial attack or healing.

Now this is a prob cause half the time, the buffbot stops too far from the offensive to keep him healed. Once combat ends, the buffbot resumes his autofollow.

It worked fine before where the buffbot would never lose autofollow....


The negatives of totally changing how the bots fight :-)

I played with 2 bots for many hours and didn't have this happen, are you saying you get beat up enough on the run back to need a heal? If so, that is the difference as I fight greens while testing - easier since I stop and start so many times.


Reply with quote
Posted: November 1st, 2005, 6:15 am
 
richyrich
richyrich's Reps:
User avatar
djvj wrote:
Some more new things I have noticed. For some reason my buffbot will try to autoattack mobs that he see's while my offensive bot is searching for the closestcon. He will take out his weapon for no reason.

One more, I know you're loving me. A couple times, out of 10 or so pulls, my offensive stopped close to where the mobs were that he pulled (not even close to the safespot and yes its set to safespot) and started fighting them there. Not to mention my buffbot typed /stopfollow a loooong ways back and isn't even close.


I'm gonna need a full log to track it down... I can't make it break so far on mine...
You can mail me at richyrich@toadmail.com and you need to define the scenario so I can have a reference of the log


Reply with quote
Posted: November 1st, 2005, 6:55 am
 
djvj

Total Posts: 272
Joined: May 1st, 2004, 4:00 am
djvj's Reps: 0
User avatar
Active User > 50 Posts
I'll try to take a look tonight at the logs after work and see if I can sort through that mess. Just usually those logs are sooo full of info it's confusing to track down specifics.

Right now 2.7 worked 10x better for my duo setup then 2.8 does. I can't even get past 3 or 4 fights w/o having to step in and correct a few mistakes of the bots.

I know you changed how the bots fight, and how I said before if the buffbot could be made to just start attacking again after its done healing. In a way you did make that happen (maybe a bit too much), but at a big cost that the buffbot doesn't heal right away anymore once the 75% health is reached. I actually like the old way the buffbot acted vs the new way better. Doesn't seem to be as ubah of a healer anymore. I have seen a group members health hit 75% and still cast an attack spell or 2 before targeting him for a heal. Then after a couple heals, another member may need healing also, but the buffbot will fire off an attack spell on the current mob before targeting the other member for a heal.

In my eyes the buffbot shouldn't even be thinking about assisting or attack spells if anybody is below 75%. And I want to help you resolve this and get it tuned right.


Reply with quote
Posted: November 1st, 2005, 7:55 am
 
richyrich
richyrich's Reps:
User avatar
djvj wrote:
I'll try to take a look tonight at the logs after work and see if I can sort through that mess. Just usually those logs are sooo full of info it's confusing to track down specifics.

Right now 2.7 worked 10x better for my duo setup then 2.8 does. I can't even get past 3 or 4 fights w/o having to step in and correct a few mistakes of the bots.

I know you changed how the bots fight, and how I said before if the buffbot could be made to just start attacking again after its done healing. In a way you did make that happen (maybe a bit too much), but at a big cost that the buffbot doesn't heal right away anymore once the 75% health is reached. I actually like the old way the buffbot acted vs the new way better. Doesn't seem to be as ubah of a healer anymore. I have seen a group members health hit 75% and still cast an attack spell or 2 before targeting him for a heal. Then after a couple heals, another member may need healing also, but the buffbot will fire off an attack spell on the current mob before targeting the other member for a heal.

In my eyes the buffbot shouldn't even be thinking about assisting or attack spells if anybody is below 75%. And I want to help you resolve this and get it tuned right.


Different people have different "needs" :-)

I agree with you, and will test it more, obviosuly I didn't test the healing bot enough in trying to get 2.8 out before putting it off again... try it as a single solo bot and give me some feedback.

I will try to do a fix soon as I don't want to take a step backwards on the healer bot which is the key tasks.


Reply with quote
Posted: November 1st, 2005, 11:27 am
 
flemer
flemer's Reps:
User avatar
Well, had great fun soloing last night, the bot worked damn well with my baby necro.
Only problem I had was when camping out. I set it to 2 hours, and after this had passed the bot tried on several occasions to camp, but interupted with an assist, on the last attempt got to 15 seconds, interupted and then the script closed. Left me stood like a lemon for 5 hours till the server went down. Good old pet looked after me though.
Think I'll change the /camp to /exit for future use. Would rather eat a death than draw attention to myself being stood in a dangerous place on numerous occasions.

Overall:
ImageImageImageImageImage
Nice one.


Reply with quote
Posted: November 1st, 2005, 12:22 pm
 
loraik
loraik's Reps:
User avatar
flemer, no worries man I will sometimes fall asleep before I hit start on my bot (yes sad I know), just looks like your afk.

An idea might be move to an area you can pull mobs to without having the roamers, typ. if you can find a good spot to solo there is normally a safe area you can pull to near by or atleast that has been my experience.



ON a seperate note, I had an issue lastnight with the clicking for lore items not working. I had the correct x,y coords in (triple checked) it would click loot item (yes) then lore verification window would pop but instead of it moving to accept it "seemed" to double click yes on lewt item again which brought up another lore window then it went off to fight leaving both lore windows up.

It lewted normal stuff without a hitch. NOTE: I do NOT have the UI/enter mod on the machine I was testing with, I wonder if that is a must.

Anyway anyone have any issues with this?

Loraik


Reply with quote
Posted: November 1st, 2005, 7:32 pm
 
loraik
loraik's Reps:
User avatar
Ok question testing two bots now healer and tank but damn healer wants to keep autofollowing the tank out to pull, how do I get him to sit still and let tank pull to him?

Loraik


Reply with quote
Posted: November 1st, 2005, 8:27 pm
 
djvj

Total Posts: 272
Joined: May 1st, 2004, 4:00 am
djvj's Reps: 0
User avatar
Active User > 50 Posts
loraik, search the script for /follow, you should be able to replace that line with anything u want or jsut delete it all together. That's the quick fix :)


Reply with quote
Posted: November 1st, 2005, 11:56 pm
 
aaliam
aaliam's Reps:
User avatar
Or just use v2.7 for your buff bot and v2.8 for attack bot. :)


Reply with quote
Posted: November 2nd, 2005, 4:18 am
 
djvj

Total Posts: 272
Joined: May 1st, 2004, 4:00 am
djvj's Reps: 0
User avatar
Active User > 50 Posts
lol aaliam, that's a pretty good idea. I had no problems on my healer in 2.7 cept he didn't revert back to attacking after everybody was healed...


Reply with quote
Posted: November 2nd, 2005, 4:33 am
 
loraik
loraik's Reps:
User avatar
I sent Richy mail about this issue as a bug, IMO this is a anoying as hell problem, if your trying to camp something from a safe location it just ain't happening.

Loraik


Reply with quote
Posted: November 2nd, 2005, 5:36 am
 
richyrich
richyrich's Reps:
User avatar
flemer wrote:
Well, had great fun soloing last night, the bot worked damn well with my baby necro.
Only problem I had was when camping out. I set it to 2 hours, and after this had passed the bot tried on several occasions to camp, but interupted with an assist, on the last attempt got to 15 seconds, interupted and then the script closed. Left me stood like a lemon for 5 hours till the server went down. Good old pet looked after me though.
Think I'll change the /camp to /exit for future use. Would rather eat a death than draw attention to myself being stood in a dangerous place on numerous occasions.

Overall:
ImageImageImageImageImage
Nice one.


hmm - ok, I can make it all /quit if needed


Reply with quote
Posted: November 2nd, 2005, 5:38 am
 
richyrich
richyrich's Reps:
User avatar
loraik wrote:
flemer, no worries man I will sometimes fall asleep before I hit start on my bot (yes sad I know), just looks like your afk.

An idea might be move to an area you can pull mobs to without having the roamers, typ. if you can find a good spot to solo there is normally a safe area you can pull to near by or atleast that has been my experience.



ON a seperate note, I had an issue lastnight with the clicking for lore items not working. I had the correct x,y coords in (triple checked) it would click loot item (yes) then lore verification window would pop but instead of it moving to accept it "seemed" to double click yes on lewt item again which brought up another lore window then it went off to fight leaving both lore windows up.

It lewted normal stuff without a hitch. NOTE: I do NOT have the UI/enter mod on the machine I was testing with, I wonder if that is a must.

Anyway anyone have any issues with this?

Loraik


After watching the bot awhile last night, I saw it pop up once. I THINK it's doing it when 2 lore items are in a box or in the same loot and it pops 2 windows up when you do loot all... and those darn boxes NEVER go away... I was going to just have it try a few places as it stacks them down and to the right... but you never really know when they are there.


Reply with quote
Want Advertisements After The Last Post Removed? Create A Free Account!

blue large dot Who is online
Users browsing this forum: No registered users and 4 guests

cron
Popular Sections
SWTOR Cheats
Guild Wars 2 Cheats
Guild Wars 2 Hacks
Guild Wars 2 Bots
Diablo 3 Cheats
Guild Wars 2 Mods

Popular Sections
WoW Cataclysm Cheats & Exploits
WoW Cataclysm Hacks & Bots
Star Wars The Old Republic Cheats
SWTOR Mods
Torchlight 2 Cheats
SWTOR Space Mission Bots
Site Nav and RSS
RSS Feed of EverQuest 2 Premium Discussions RSS Feed 
Sitemap of EverQuest 2 Premium Discussions Sitemap 
SitemapIndex SitemapIndex
RSS Feed RSS Feed
Channel list Channel list
left bottom corner Site and Contents Copyright 2001-2012 All Rights Reserved TaultUnleashed.com bottom corner
top left
top right
createaccount
Username:   Password:   Remember Me?